Май 042024
 

arcgis  logo Возникла необходимость привязки полноценного (не само подписанного) сертификата к серверу публикации ArcGIS, в связи с тем, что при запросе с сервера начинает ругаться на несоответствие сертификата безопасности (не мудрено). Задача не совсем тривиальная, так как публикатор ArcGis использует не совсем стандартые методы, и не использует полноценно IIS. Для того, чтобы все корректно сработало, нам необходим сертификат в формате .pkcs #12, который не совсем просто получить в исходном виде, так как большинство провайдеров выпущенный сертификат отдают нам в любимом формате «великой тройки» — сам сертификат, промежуточный сертификат, и ключ. По итогу, что с этим делать, и в какой последовательности, мы и разберем.
Continue reading »

Мар 062024
 

Cron — один из часто используемых инструментов для Unix-систем. Его используют для планирования выполнения команд на определённое время. Эти «отложенные» команды или задания принято называть «Cron Jobs». Такой инструмент отлично подходит для регулярных бэкапов, мониторинга дискового пространства, удаления файлов (например, логов) и много чего ещё. В этой статье будет рассказано о работе с Cron на Linux.
Continue reading »

Фев 082024
 

Вот и пришла пора вступить на тернистый путь контроля версий git, после теплого и лампового SVN. Для начала утоним, чем же хорош этот пресловутый инструментарий. GitLab — это проект, который используя систему управления репозиториями git полностью обеспечивает жизненный цикл DevOps, включая wiki, CI/CD и многое другое. По сравнению с другими версиями GitLab, Community Edition предоставляет ограниченный набор функций, но все же является мощным инструментом для управления проектами разработки ПО. Корпоративные версии предоставляют более широкие возможности, такие как расширенная аналитика, аварийное восстановление и средства безопасности.
Continue reading »

Янв 262024
 

mikrotik logoНеобходимость в применении данной процедуры может возникнуть при замене сетевого оборудования, когда провайдер фиксирует MAC адрес клиента для повышения уровня безопасности соединения. Однако используя WinBox оказывается, что это опция закрыта от прямого редактирования.
Для изменения MAC адреса в оборудовании MikroTik нужно ввести команду в терминале

/interface ethernet set ether1 mac-address=00:00:00:00:00:01

Как узнать имя интерфейса(порта) по умолчанию

/interface ethernet print detail

Как установить имя интерфейса(порта) по умолчанию

/interface ethernet set [ find default-name=ether1 ] name=ether1

Изменить MAC для bridge

/interface bridge set Bridge1 admin-mac=00:00:00:00:00:02 auto-mac=no
Янв 122024
 

mikrotik logo 1. Убедитесь, что у вас есть пакеты npk того же типа архитектуры, что и ваше устройство.
2. Загрузите файлы npk более старой версии на устройство с помощью FTP, Webfig или Winbox.
3. Выполните команду:

/system/package/downgrade

4. Нажмите Y для перезагрузки устройства

Янв 042024
 

cook
Красную рыбу (у меня свежемороженая форель) тщательно промойте, почистите от пленок, если есть плавники — удалите. Нарежьте на порционные куски вдоль хребта или на стейки. Рыбу посолите, поперчите. Красную рыбу можно использовать любую: форель, семгу или горбушу. Стоит учесть, что если используете горбушу, то эта рыба не такая жирная, как семга и форель, поэтому дополнительно нужно смазать рыбу растительным маслом.
Continue reading »

Дек 242023
 

Ну что, вот и я решил для начинающих собрать основной костяк необходимого материала, чтобы начать без особых проблем работу с этим не самым продуктивным, но получившим бешенную популярность девайсом. Конечно, на рынке после него появилось куча клонов, подражателей и более мощных устройств, но основоположником и «закладывателем» канонов можно с уверенностью сказать стал именно Raspberry Pi. Уже появилась не одна итерация этого замечательного устройства, в чем то хуже, в чем то лучше предшественника, но сегодня за основу мы возьмем Raspberry Pi 3B+. Все, что будет написано ниже, точно будет работать (да и я уверен, что большинство команд будет работать и на более поздних и ранних устройствах, так как совместимость бешенная). Итак, к топкам.
Continue reading »

Дек 242023
 

Home Assistant Как вы и догадались, Raspberry Pi не с проста появилось в моем арсенале. Пришло понимание, что захотелось получить у себя в распоряжение частичку умного дома, да не просто умного, но и помогающего в прогрессирующей лени. Показания счетчиков списать не залезая в темный угол, успокоить свою паранойю, что свет в доме выключил, камеры при необходимости посмотреть, что с машиной все в порядке и тому подобное. Т.е. по сути сделать свою жизнь немного комфортнее. Этим я и займусь, а пока постигаю азы необходимого, для создания этого комфортного образа жизни.
Continue reading »

Дек 242023
 

Home AssistantПо умолчанию в операционной системе HassOS с Home Assistant на борту ssh отключен. И по сути он и не нужен. Все настройки можно производить не подключаясь по ssh к серверу. Но все-же если Вам хочется там посмотреть что либо или вы знаете конкретно что Вам нужно от консоли HassOS. То как-раз для Вас эта статья. Тут я вкратце расскажу что нужно сделать, чтоб открыть доступ ssh в HassOS.
Continue reading »

Ноя 302023
 

cookСливочный суп 🍜 Как вам рецепт? Будете пробовать?
Тебе понадобится:
1. Куриное филе — 2 шт.
2. Перец сладкий — 1 шт.
3. Помидоры — 2 шт.
4. Чеснок — 2 зубчика.
5. Сливки 20 % — 150 мл.
6. Макароны — горсть.
7. Петрушка — пару веток.

Этапы приготовления:
1️⃣. Куриное филе разрезаем вдоль на. 2 части. Приправляем паприкой, солью, специями для курицы, каплю масла и Марину 20 минут.
2️⃣. Обжариваем до золотистости. Убираем с огня.
3️⃣. Закидываем перец и лук, через 5 минут помидоры, чеснок. Заливаем кипятком, закидываем макароны. Варим до их готовности. Возвращаем курицу.
4️⃣. Наливаем сливки, добавляем зелень. Выключаем огонь. Можно подавать, это очень вкусно, обязательно попробуйте приготовить!

Полезные ссылки:
сливочный суп